The latest version of Vine Server (3.0) only officially works with Mac OS X 10.4 or later, but there’s a way to make it work with Mac OS X 10.3 (Panther). After installing Vine normally, just delete the following directory. It contains the offending OS X 10.5 (Leopard) specific files:

/Applications/Vine Server.app/Content/Resources/TigerBundle.bundle

That’s it! You should now be able to launch Vine’s VNC Server from the Applications Folder, configure it, and remotely control to your Mac OS X 10.3 system over the network.